Work is underway on adding GTK+ and
GNOME support to Gwydion Dylan.
If you would like to help, please join the mailing list.

We’d eventually like to support DUIM (the Dylan User
Interface Manager) as a wrapper around GTK+ and GNOME.
This probably involves a huge amount of work.


Improve Melange: progress8
Wrap GLib: progress8
Wrap GDK: progress1
Wrap GTK+: progress4
Wrap GNOME: progress0
Dylan-like interfaces: progress0
Implement DUIM: progress0

Note that OpenDylan already has a GTK+ backend for DUIM.
While this code has been suffering from bit rot for the last
few years—the main problem being that it doesn’t
support GTK+ 2.0—renovation work has been started.